51 lines
1.2 KiB
Bash
51 lines
1.2 KiB
Bash
# Maintainer: Danct12 <danct12@disroot.org>
|
|
# Contributor: Bernhard Landauer <bernhard@manjaro.org>
|
|
# Contributor: dodgejcr@gmail.com
|
|
# Contributor: Bhushan Shah <bhush94 at gmail dot com>
|
|
|
|
pkgname=spacebar
|
|
pkgver=24.02.0
|
|
pkgrel=2
|
|
pkgdesc="SMS and messaging application for Mobile Devices running Plasma"
|
|
arch=('x86_64' 'armv7h' 'aarch64')
|
|
url="https://community.kde.org/Plasma/Mobile"
|
|
license=('GPL-2.0-only OR GPL-3.0-only')
|
|
depends=(
|
|
'c-ares'
|
|
'futuresql-qt6'
|
|
'kconfig'
|
|
'kcoreaddons'
|
|
'kcontacts'
|
|
'kdbusaddons'
|
|
'ki18n'
|
|
'kio'
|
|
'kirigami'
|
|
'kirigami-addons'
|
|
'knotifications'
|
|
'kpeople'
|
|
'kwindowsystem'
|
|
'libphonenumber'
|
|
'modemmanager-qt'
|
|
'qcoro-qt6'
|
|
'qt6-declarative'
|
|
)
|
|
makedepends=(
|
|
'cmake'
|
|
'extra-cmake-modules'
|
|
)
|
|
#source=("http://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz")
|
|
#sha256sums=('b5c7b5c58cba9250bffa0fb88f7cd3fb712bfc112fb1716ef9b1c07f0bd6d2ca')
|
|
source=("$pkgname-$pkgver.tar.gz::https://invent.kde.org/plasma-mobile/spacebar/-/archive/master/spacebar-master.tar.gz")
|
|
sha256sums=('SKIP')
|
|
|
|
build() {
|
|
# cmake -B build -S $pkgname-$pkgver \
|
|
cmake -B build -S $pkgname-master \
|
|
-DCMAKE_INSTALL_LIBEXECDIR=lib \
|
|
-DBUILD_TESTING=OFF
|
|
cmake --build build
|
|
}
|
|
|
|
package() {
|
|
DESTDIR="$pkgdir" cmake --install build
|
|
}
|